// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b(ALLEE|ANSE|AVENUE|BOULEVARD|CARREFOUR|CHAUSSEE|CHEMIN|CITE|CLOS|COTE|COUR|COURS|DEGRE|DESCENTE|DREVE|ESCOUSSIERE|ESPLANADE|GAFFE|GRAND-ROUTE|IMPASSE|LIAISON|MAIL|MONTEE|PASSAGE|PLACE|PLACETTE|PONT|PROMENADE|QUAI|RESIDENCE|RANG|RAMPE|ROND-POINT|ROUTE|RUE|RUELLE|SENTE|SENTIER|SQUARE|TRABOULE|TRAVERSE|VENELLE|VILLA|VOIE|BERGE|DIGUE|CUL-DE-SAC|ESCALIER|GIRATOIRE|JARDIN|PARVIS|PASSERELLE)\b").unwrap();
let string = "ALLEE RUE ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}