use strict;
my $str = 'ALLEE RUE ';
my $regex = qr/\b(ALLEE|ANSE|AVENUE|BOULEVARD|CARREFOUR|CHAUSSEE|CHEMIN|CITE|CLOS|COTE|COUR|COURS|DEGRE|DESCENTE|DREVE|ESCOUSSIERE|ESPLANADE|GAFFE|GRAND-ROUTE|IMPASSE|LIAISON|MAIL|MONTEE|PASSAGE|PLACE|PLACETTE|PONT|PROMENADE|QUAI|RESIDENCE|RANG|RAMPE|ROND-POINT|ROUTE|RUE|RUELLE|SENTE|SENTIER|SQUARE|TRABOULE|TRAVERSE|VENELLE|VILLA|VOIE|BERGE|DIGUE|CUL-DE-SAC|ESCALIER|GIRATOIRE|JARDIN|PARVIS|PASSERELLE)\b/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}