re = /\b(ALLEE|ANSE|AVENUE|BOULEVARD|CARREFOUR|CHAUSSEE|CHEMIN|CITE|CLOS|COTE|COUR|COURS|DEGRE|DESCENTE|DREVE|ESCOUSSIERE|ESPLANADE|GAFFE|GRAND-ROUTE|IMPASSE|LIAISON|MAIL|MONTEE|PASSAGE|PLACE|PLACETTE|PONT|PROMENADE|QUAI|RESIDENCE|RANG|RAMPE|ROND-POINT|ROUTE|RUE|RUELLE|SENTE|SENTIER|SQUARE|TRABOULE|TRAVERSE|VENELLE|VILLA|VOIE|BERGE|DIGUE|CUL-DE-SAC|ESCALIER|GIRATOIRE|JARDIN|PARVIS|PASSERELLE)\b/m
str = 'ALLEE RUE '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end