import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([0-9]+)\\s([A-Za-z0-9\\-\\s]+)\\,\\s([A-Za-z\\s]+)\\,\\s([A-Z]{2})\\s([0-9\\-]{5,10})";
final String string = "123 Riverview Pkwy, Orlando, FL 55556\n"
+ "12 Street Pkwy, Miami, FL 98989\n"
+ "18 Street Pkwy, TAMPA, FL 80148-0980\n"
+ "18 Street 76 PKWY, TAMPA, FL 80148-0980\n"
+ "18 Goerge-Washington Street 76 Pkwy, Tampa, FL 80148-0980\n"
+ "18 Street Pkwy, Tampa, FL 80148-0980989";
final String subst = "$2 $3 $4 $5";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}