import Foundation
let pattern = #"([0-9]+)\s([A-Za-z0-9\-\s]+)\,\s([A-Za-z\s]+)\,\s([A-Z]{2})\s([0-9\-]{5,10})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
123 Riverview Pkwy, Orlando, FL 55556
12 Street Pkwy, Miami, FL 98989
18 Street Pkwy, TAMPA, FL 80148-0980
18 Street 76 PKWY, TAMPA, FL 80148-0980
18 Goerge-Washington Street 76 Pkwy, Tampa, FL 80148-0980
18 Street Pkwy, Tampa, FL 80148-0980989
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$2 $3 $4 $5"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)