use strict;
my $str = '123 Riverview Pkwy, Orlando, FL 55556
12 Street Pkwy, Miami, FL 98989
18 Street Pkwy, TAMPA, FL 80148-0980
18 Street 76 PKWY, TAMPA, FL 80148-0980
18 Goerge-Washington Street 76 Pkwy, Tampa, FL 80148-0980
18 Street Pkwy, Tampa, FL 80148-0980989';
my $regex = qr/([0-9]+)\s([A-Za-z0-9\-\s]+)\,\s([A-Za-z\s]+)\,\s([A-Z]{2})\s([0-9\-]{5,10})/mp;
my $subst = '$2 $3 $4 $5';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";