package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)(?:(?:http|https):\/\/)?(?:www.)?(?:instagram.com|instagr.am|instagr.com)\/(\w+)`)
var str = `http://instagram.com/username
http://instagram.com/username?modal=true
https://instagram.com/username
https://instagram.com/username?modal=true
http://www.instagram.com/username
http://www.instagram.com/username?modal=true
https://www.instagram.com/username
https://www.instagram.com/username?modal=true
instagram.com/username
instagram.com/username?modal=true
www.instagram.com/username
www.instagram.com/username?modal=true
http://instagr.am/username
http://instagr.am/username?modal=true
http://www.instagr.am/username
http://www.instagr.am/username?modal=true
https://instagr.am/username
https://instagr.com/username
https://instagr.am/username?modal=true
https://www.instagr.am/username
https://www.instagr.am/username?modal=true`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}