// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)(?:(?:http|https):\/\/)?(?:www.)?(?:instagram.com|instagr.am|instagr.com)\/(\w+)").unwrap();
let string = "http://instagram.com/username
http://instagram.com/username?modal=true
https://instagram.com/username
https://instagram.com/username?modal=true
http://www.instagram.com/username
http://www.instagram.com/username?modal=true
https://www.instagram.com/username
https://www.instagram.com/username?modal=true
instagram.com/username
instagram.com/username?modal=true
www.instagram.com/username
www.instagram.com/username?modal=true
http://instagr.am/username
http://instagr.am/username?modal=true
http://www.instagr.am/username
http://www.instagr.am/username?modal=true
https://instagr.am/username
https://instagr.com/username
https://instagr.am/username?modal=true
https://www.instagr.am/username
https://www.instagr.am/username?modal=true";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}