package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:(?:\w+)(?:\[(?:\d*|'[^']*')\])?=[\w%]*(?:&|$))*$`)
var str = `hello=value&am=i
hellp
help=me
pleas=help&me=plz&var[]=true
pleas=&me=&var[]=
helo&ewepcmwep&lalal=true
pleas=help&me=plz&var[]=true&var[2]=false&var['blahblah']=ipsum`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}