re = /^(?:(?:\w+)(?:\[(?:\d*|'[^']*')\])?=[\w%]*(?:&|$))*$/m
str = 'hello=value&am=i
hellp
help=me
pleas=help&me=plz&var[]=true
pleas=&me=&var[]=
helo&ewepcmwep&lalal=true
pleas=help&me=plz&var[]=true&var[2]=false&var[\'blahblah\']=ipsum'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end