using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\s*(?:\s*\w+\s*,\s*){3}\w+\s*>\s*\w+,(?!.*[,>]).*$";
string input = @"abcd, afsfsfs, abcdef, 90> 20, abeds afdasdf asdf
abcd, afsfsfs, abcdef, 90> 20
a.d.d.e.elja.welrjk
abcd, afsfsfs, abcdef, 90> 20, abeds afdasdf , > asdf
abcd, afsfsfs, abcdef, 90> 20, abeds afdasdf , asdf
abcd, afsfsfs, abcdef, 90> 20, abeds afdasdf asdf
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}