const regex = /^\s*(?:\s*\w+\s*,\s*){3}\w+\s*>\s*\w+,(?!.*[,>]).*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s*(?:\\s*\\w+\\s*,\\s*){3}\\w+\\s*>\\s*\\w+,(?!.*[,>]).*$', 'gm')
const str = `abcd, afsfsfs, abcdef, 90> 20, abeds afdasdf asdf
abcd, afsfsfs, abcdef, 90> 20
a.d.d.e.elja.welrjk
abcd, afsfsfs, abcdef, 90> 20, abeds afdasdf , > asdf
abcd, afsfsfs, abcdef, 90> 20, abeds afdasdf , asdf
abcd, afsfsfs, abcdef, 90> 20, abeds afdasdf asdf
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}