$re = '/^\s*(?:\s*\w+\s*,\s*){3}\w+\s*>\s*\w+,(?!.*[,>]).*$/m';
$str = 'abcd, afsfsfs, abcdef, 90> 20, abeds afdasdf asdf
abcd, afsfsfs, abcdef, 90> 20
a.d.d.e.elja.welrjk
abcd, afsfsfs, abcdef, 90> 20, abeds afdasdf , > asdf
abcd, afsfsfs, abcdef, 90> 20, abeds afdasdf , asdf
abcd, afsfsfs, abcdef, 90> 20, abeds afdasdf asdf
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);