import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*(?:\\s*\\w+\\s*,\\s*){3}\\w+\\s*>\\s*\\w+,(?!.*[,>]).*$";
final String string = "abcd, afsfsfs, abcdef, 90> 20, abeds afdasdf asdf\n"
+ "abcd, afsfsfs, abcdef, 90> 20\n"
+ "a.d.d.e.elja.welrjk\n"
+ "abcd, afsfsfs, abcdef, 90> 20, abeds afdasdf , > asdf\n"
+ "abcd, afsfsfs, abcdef, 90> 20, abeds afdasdf , asdf\n"
+ "abcd, afsfsfs, abcdef, 90> 20, abeds afdasdf asdf\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}