use strict;
my $str = 'abcd, afsfsfs, abcdef, 90> 20, abeds afdasdf asdf
abcd, afsfsfs, abcdef, 90> 20
a.d.d.e.elja.welrjk
abcd, afsfsfs, abcdef, 90> 20, abeds afdasdf , > asdf
abcd, afsfsfs, abcdef, 90> 20, abeds afdasdf , asdf
abcd, afsfsfs, abcdef, 90> 20, abeds afdasdf asdf
';
my $regex = qr/^\s*(?:\s*\w+\s*,\s*){3}\w+\s*>\s*\w+,(?!.*[,>]).*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}