import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*(?P<IgnoreBracket>\\(?)(?P<area_code>\\d{3}?|\\d{3})(?P<IgnoreBracket2>\\s|\\)?)(?P<IgnoreSpecChar>\\s*?|-?)(?P<first_three>\\d{3})(?P<IgnoreSpecChar1>-?)(?P<last_four>\\d{4})\\s*?";
final String string = "(404-555-1212\n\n\n\n"
+ "^(?P<IgnoreBracket>\\(?)(?P<area_code>\\d{3}?|\\d{3})(?P<IgnoreBracket2>\\)?)(\\s*?|-?)(?P<first_three>\\d{3})-?(?P<last_four>\\d{4})\\s*?\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}