import re
regex = re.compile(r"^\s*(?P<IgnoreBracket>\(?)(?P<area_code>\d{3}?|\d{3})(?P<IgnoreBracket2>\s|\)?)(?P<IgnoreSpecChar>\s*?|-?)(?P<first_three>\d{3})(?P<IgnoreSpecChar1>-?)(?P<last_four>\d{4})\s*?", flags=re.MULTILINE)
test_str = ("(404-555-1212\n\n\n\n"
"^(?P<IgnoreBracket>\\(?)(?P<area_code>\\d{3}?|\\d{3})(?P<IgnoreBracket2>\\)?)(\\s*?|-?)(?P<first_three>\\d{3})-?(?P<last_four>\\d{4})\\s*?\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")