#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^((?P<all>apple|bat|car)), (?!\1)((?P>all)), (?!\1|\2)((?P>all))$"
Local $sString = "apple, bat, car" & @CRLF & _
"apple, car, bat" & @CRLF & _
"bat, apple, car" & @CRLF & _
"car, bat, apple" & @CRLF & _
"" & @CRLF & _
"FAILS" & @CRLF & _
"" & @CRLF & _
"apple, bat, car, d" & @CRLF & _
"d, apple, bat, car" & @CRLF & _
"apple, bat, d, car" & @CRLF & _
"apple, apple, car" & @CRLF & _
"apple, apple, apple"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")