import Foundation
let pattern = #"^((?P<all>apple|bat|car)), (?!\1)((?P>all)), (?!\1|\2)((?P>all))$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
apple, bat, car
apple, car, bat
bat, apple, car
car, bat, apple
FAILS
apple, bat, car, d
d, apple, bat, car
apple, bat, d, car
apple, apple, car
apple, apple, apple
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)