import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?P<all>apple|bat|car)), (?!\\1)((?P>all)), (?!\\1|\\2)((?P>all))$";
final String string = "apple, bat, car\n"
+ "apple, car, bat\n"
+ "bat, apple, car\n"
+ "car, bat, apple\n\n"
+ "FAILS\n\n"
+ "apple, bat, car, d\n"
+ "d, apple, bat, car\n"
+ "apple, bat, d, car\n"
+ "apple, apple, car\n"
+ "apple, apple, apple";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}