use strict;
my $str = 'apple, bat, car
apple, car, bat
bat, apple, car
car, bat, apple
FAILS
apple, bat, car, d
d, apple, bat, car
apple, bat, d, car
apple, apple, car
apple, apple, apple';
my $regex = qr/^((?P<all>apple|bat|car)), (?!\1)((?P>all)), (?!\1|\2)((?P>all))$/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}