using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\w+(?: \w+)*({(?:[^{}]++|(?1))*})";
string input = @"void function{ { { } }}
static stTLookupTable RxTable[MAX]={
{zero, one},{zero, one},{zero, one}};";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}