import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\w+(?: \\w+)*(\\{(?:[^\\{\\}]++|(?1))*\\})";
final String string = "void function{ { { } }} \n\n\n"
+ "static stTLookupTable RxTable[MAX]={\n"
+ " \n"
+ " {zero, one},{zero, one},{zero, one}};";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}