package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\w+(?: \w+)*({(?:[^{}]++|(?1))*})`)
var str = `void function{ { { } }}
static stTLookupTable RxTable[MAX]={
{zero, one},{zero, one},{zero, one}};`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}