re = /\w+(?: \w+)*({(?:[^{}]++|(?1))*})/m
str = 'void function{ { { } }}
static stTLookupTable RxTable[MAX]={
{zero, one},{zero, one},{zero, one}};'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end