#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ",(?=(?:[^\"]*\"[^\"]*\")*[^\"]*$)"
Local $sString = "1234,"Calle Jaime III, 34", 67,3,U" & @CRLF & _
"1235,Avenida Los Algodones, 12,1,L" & @CRLF & _
"1236,"Calle Principal""31234", 46,3,H" & @CRLF & _
"1237,"Calle Alfonso X,22", 65,2,J"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")