import Foundation
let pattern = #",(?=(?:[^\"]*\"[^\"]*\")*[^\"]*$)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
1234,"Calle Jaime III, 34", 67,3,U
1235,Avenida Los Algodones, 12,1,L
1236,"Calle Principal""31234", 46,3,H
1237,"Calle Alfonso X,22", 65,2,J
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)