const regex = /,(?=(?:[^\"]*\"[^\"]*\")*[^\"]*$)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(',(?=(?:[^\\"]*\\"[^\\"]*\\")*[^\\"]*$)', 'g')
const str = `1234,"Calle Jaime III, 34", 67,3,U
1235,Avenida Los Algodones, 12,1,L
1236,"Calle Principal""31234", 46,3,H
1237,"Calle Alfonso X,22", 65,2,J`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}