use strict;
my $str = '1234,"Calle Jaime III, 34", 67,3,U
1235,Avenida Los Algodones, 12,1,L
1236,"Calle Principal""31234", 46,3,H
1237,"Calle Alfonso X,22", 65,2,J';
my $regex = qr/,(?=(?:[^\"]*\"[^\"]*\")*[^\"]*$)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}