re = /,(?=(?:[^\"]*\"[^\"]*\")*[^\"]*$)/
str = '1234,"Calle Jaime III, 34", 67,3,U
1235,Avenida Los Algodones, 12,1,L
1236,"Calle Principal""31234", 46,3,H
1237,"Calle Alfonso X,22", 65,2,J'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end