package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\bhref="([^"]+\bfref=fr_tab\b[^"]*)"`)
var str = `href="?fref=fr_tab"
href="https://www.test.com?fref=fr_tab"
href="https://www.test.com?a=1&fref=fr_tab"
href="https://www.test.com?a=1;fref=fr_tab"
href="https://www.test.com?a=1;fref=fr_tab;b=2"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}