re = /\bhref="([^"]+\bfref=fr_tab\b[^"]*)"/m
str = 'href="?fref=fr_tab"
href="https://www.test.com?fref=fr_tab"
href="https://www.test.com?a=1&fref=fr_tab"
href="https://www.test.com?a=1;fref=fr_tab"
href="https://www.test.com?a=1;fref=fr_tab;b=2"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end