import re
regex = re.compile(r"\bhref=\"([^\"]+\bfref=fr_tab\b[^\"]*)\"", flags=re.MULTILINE)
test_str = ("href=\"?fref=fr_tab\"\n"
"href=\"https://www.test.com?fref=fr_tab\"\n"
"href=\"https://www.test.com?a=1&fref=fr_tab\"\n"
"href=\"https://www.test.com?a=1;fref=fr_tab\"\n"
"href=\"https://www.test.com?a=1;fref=fr_tab;b=2\"")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")