$re = '/\bhref="([^"]+\bfref=fr_tab\b[^"]*)"/m';
$str = 'href="?fref=fr_tab"
href="https://www.test.com?fref=fr_tab"
href="https://www.test.com?a=1&fref=fr_tab"
href="https://www.test.com?a=1;fref=fr_tab"
href="https://www.test.com?a=1;fref=fr_tab;b=2"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);