import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bhref=\"([^\"]+\\bfref=fr_tab\\b[^\"]*)\"";
final String string = "href=\"?fref=fr_tab\"\n"
+ "href=\"https://www.test.com?fref=fr_tab\"\n"
+ "href=\"https://www.test.com?a=1&fref=fr_tab\"\n"
+ "href=\"https://www.test.com?a=1;fref=fr_tab\"\n"
+ "href=\"https://www.test.com?a=1;fref=fr_tab;b=2\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}