const regex = new RegExp('\\s*(?:abc|sst)\\w*', 'gm')
const str = `error in node occurred in sstlgh8j at 10pm afterabchjk9j after 12pm
error in node occurredsstlgh8j at 10pm after abchjk9j after 12pm`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);