import Foundation
let pattern = #"\s*(?:abc|sst)\w*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
error in node occurred in sstlgh8j at 10pm afterabchjk9j after 12pm
error in node occurredsstlgh8j at 10pm after abchjk9j after 12pm
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)