import re
regex = re.compile(r"\s*(?:abc|sst)\w*", flags=re.MULTILINE)
test_str = ("error in node occurred in sstlgh8j at 10pm afterabchjk9j after 12pm\n"
"error in node occurredsstlgh8j at 10pm after abchjk9j after 12pm")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)