using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<([A-Za-z_{}()/]+(\s|=)*)+>(.*<[A-Za-z/>]+)*";
string input = @"<img src=x onerror=do_evil()/>
<script>$(blabla).click();</script>";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}