// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)<([A-Za-z_{}()/]+(\s|=)*)+>(.*<[A-Za-z/>]+)*").unwrap();
let string = "<img src=x onerror=do_evil()/>
<script>$(blabla).click();</script>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}