package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)<([A-Za-z_{}()/]+(\s|=)*)+>(.*<[A-Za-z/>]+)*`)
var str = `<img src=x onerror=do_evil()/>
<script>$(blabla).click();</script>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}