re = /<([A-Za-z_{}()\/]+(\s|=)*)+>(.*<[A-Za-z\/>]+)*/i
str = '<img src=x onerror=do_evil()/>
<script>$(blabla).click();</script>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end