using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b\d{6}(?:-[a-zA-Z]+)+\b";
string input = @"200502-title-of-something
123-blah-blah
1234567-blah
123456-*$=è
jhsdf123456lkqjsdflk
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}