re = /\b\d{6}(?:-[a-zA-Z]+)+\b/m
str = '200502-title-of-something
123-blah-blah
1234567-blah
123456-*$=è
jhsdf123456lkqjsdflk
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end