$re = '/\b\d{6}(?:-[a-zA-Z]+)+\b/m';
$str = '200502-title-of-something
123-blah-blah
1234567-blah
123456-*$=è
jhsdf123456lkqjsdflk
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);