// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b\d{6}(?:-[a-zA-Z]+)+\b").unwrap();
let string = "200502-title-of-something
123-blah-blah
1234567-blah
123456-*$=è
jhsdf123456lkqjsdflk
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}