package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b\d{6}(?:-[a-zA-Z]+)+\b`)
var str = `200502-title-of-something
123-blah-blah
1234567-blah
123456-*$=è
jhsdf123456lkqjsdflk
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}