import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "extend\\s+([^n]*)(?:(?P<phase>colloid|mineral|basis|isotope|solid-solution)\\s+)?(?P<species>[^\\n ]+)\\s+(\\{(?P<content>((?:[^\\{\\}]++|(?4))*))\\})";
final String string = "extend mineral Uraninite {\n"
+ " kinetics {\n"
+ " rate = -3.2e-08 mol/m2/s\n"
+ " area = Uraninite\n"
+ " y-term, species = Uraninite\n"
+ " w-term {\n"
+ " species = H[+]\n"
+ " power = 0.37\n"
+ " }\n"
+ " }\n"
+ " kinetics {\n"
+ " rate = 3.2e-09 mol/m2/s\n"
+ " area = Uraninite\n"
+ " y-term, species = Uraninite\n"
+ " w-term {\n"
+ " species = H[+]\n"
+ " power = 0.37\n"
+ " }\n"
+ " }\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}