// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)extend\s+([^n]*)(?:(?P<phase>colloid|mineral|basis|isotope|solid-solution)\s+)?(?P<species>[^\n ]+)\s+({(?P<content>((?:[^{}]++|(?4))*))})").unwrap();
let string = "extend mineral Uraninite {
kinetics {
rate = -3.2e-08 mol/m2/s
area = Uraninite
y-term, species = Uraninite
w-term {
species = H[+]
power = 0.37
}
}
kinetics {
rate = 3.2e-09 mol/m2/s
area = Uraninite
y-term, species = Uraninite
w-term {
species = H[+]
power = 0.37
}
}
}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}