# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"extend\s+([^n]*)(?:(?P<phase>colloid|mineral|basis|isotope|solid-solution)\s+)?(?P<species>[^\n ]+)\s+({(?P<content>((?:[^{}]++|(?4))*))})"
test_str = ("extend mineral Uraninite {\n"
" kinetics {\n"
" rate = -3.2e-08 mol/m2/s\n"
" area = Uraninite\n"
" y-term, species = Uraninite\n"
" w-term {\n"
" species = H[+]\n"
" power = 0.37\n"
" }\n"
" }\n"
" kinetics {\n"
" rate = 3.2e-09 mol/m2/s\n"
" area = Uraninite\n"
" y-term, species = Uraninite\n"
" w-term {\n"
" species = H[+]\n"
" power = 0.37\n"
" }\n"
" }\n"
"}")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.